summaryrefslogtreecommitdiff
path: root/software/CMakeLists.txt
diff options
context:
space:
mode:
authorEric Dao <eric@erickhangdao.com>2022-07-09 22:38:28 -0400
committerEric Dao <eric@erickhangdao.com>2022-07-09 22:38:28 -0400
commitcb234a53f606de8bd136b596a316e912ddf15185 (patch)
treec5f4bf00e4e7e038c24f4ff79f3c5f7af9474ca9 /software/CMakeLists.txt
parent9dd37009b3dc7d4d155f5c1a529ace46e55c8e0d (diff)
downloadmotorized_blinds-master.tar.gz
motorized_blinds-master.tar.bz2
motorized_blinds-master.zip
added licenseHEADmaster
Diffstat (limited to 'software/CMakeLists.txt')
-rw-r--r--software/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/software/CMakeLists.txt b/software/CMakeLists.txt
new file mode 100644
index 0000000..1f56563
--- /dev/null
+++ b/software/CMakeLists.txt
@@ -0,0 +1,6 @@
+# The following five lines of boilerplate have to be in your project's
+# CMakeLists in this exact order for cmake to work correctly
+cmake_minimum_required(VERSION 3.5)
+
+include($ENV{IDF_PATH}/tools/cmake/project.cmake)
+project(automatic-blind-actuator)