summaryrefslogtreecommitdiff
path: root/software/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'software/CMakeLists.txt')
-rw-r--r--software/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/software/CMakeLists.txt b/software/CMakeLists.txt
new file mode 100644
index 0000000..1f56563
--- /dev/null
+++ b/software/CMakeLists.txt
@@ -0,0 +1,6 @@
+# The following five lines of boilerplate have to be in your project's
+# CMakeLists in this exact order for cmake to work correctly
+cmake_minimum_required(VERSION 3.5)
+
+include($ENV{IDF_PATH}/tools/cmake/project.cmake)
+project(automatic-blind-actuator)